Tuesday, February 16, 2016

Cisco Router -3760G Switch VLAN /Interface/Routing Configuration

Set Clock Enable VLAN and Add Default route

dk_lab#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
dk_lab(config)#vlan 19
dk_lab(config-vlan)#name Web-Backend
dk_lab(config-vlan)#int Gi1/0/13
dk_lab(config-if)#switchport access vlan 19
dk_lab(config-if)#int Gi1/0/14
dk_lab(config-if)#switchport access vlan 19
dk_lab(config-if)#int Gi1/0/15
dk_lab(config-if)#switchport access vlan 19
dk_lab(config-if)#int Gi1/0/16
dk_lab(config-if)#switchport access vlan 19
dk_lab(config-if)#


dk_lab#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
dk_lab(config)#vlan 16
dk_lab(config-vlan)#name Servers
dk_lab(config-vlan)#vlan 17
dk_lab(config-vlan)#name Web-Backend
%VLAN #17 and #18 have an identical name: Web-Backend
dk_lab(config-vlan)#name Web-Backends



dk_lab#sh vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Gi1/0/17, Gi1/0/18, Gi1/0/19
                                                Gi1/0/20, Gi1/0/21, Gi1/0/22
                                                Gi1/0/23, Gi1/0/24, Gi1/0/25
                                                Gi1/0/26, Gi1/0/27, Gi1/0/28

16   Server                           active    Gi1/0/1, Gi1/0/2, Gi1/0/3  Gi1/0/4

17   Web-Backend                      active    Gi1/0/5, Gi1/0/6, Gi1/0/7   Gi1/0/8
                                             

18   Distribution                     active    Gi1/0/9, Gi1/0/10, Gi1/0/11   Gi1/0/12
                                             


19   Ad-Test                          active    Gi1/0/13, Gi1/0/14, Gi1/0/15   Gi1/0/16
                                             
1002 fddi-default                     act/unsup





DK_Lab_SW#clock set 12:49:00 01 December 2013
DK_Lab_SW#
01:55:14: %SYS-6-CLOCKUPDATE: System clock has been updated from 20:55:14 EST Sun Feb 28 1993 to 12:49:00 EST Sun Dec 1 2013, configured from console by console.
DK_Lab_SW#wr t
Building configuration...

DK_Lab_SW#sh clock
12:51:14.184 EST Sun Dec 1 2013
DK_Lab_SW#
------

DK_Lab_SW(config)#ip routing
DK_Lab_SW(config)#ip subnet-zero
DK_Lab_SW(config)#ip route 0.0.0.0 0.0.0.0 172.20.35.244
DK_Lab_SW(config)#^Z
DK_Lab_SW#



Switch(config)#hostname DK_Lab_SW
DK_Lab_SW(config)#vlan 10
DK_Lab_SW(config-vlan)#name Core

DK_Lab_SW(config-vlan)#vlan 20
DK_Lab_SW(config-vlan)#name DMZ

DK_Lab_SW(config-vlan)#vlan 30
DK_Lab_SW(config-vlan)#name Internet
DK_Lab_SW(config-vlan)#
DK_Lab_SW(config-vlan)#^Z
DK_Lab_SW#


--Validate VLANs were created


DK_Lab_SW#sh vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Gi2/0/1, Gi2/0/2, Gi2/0/3
                                                Gi2/0/4, Gi2/0/5, Gi2/0/6
                                                Gi2/0/7, Gi2/0/8, Gi2/0/9
                                                Gi2/0/10, Gi2/0/11, Gi2/0/12
                                                Gi2/0/13, Gi2/0/14, Gi2/0/15
                                                Gi2/0/16, Gi2/0/17, Gi2/0/18
                                                Gi2/0/19, Gi2/0/20, Gi2/0/21
                                                Gi2/0/22, Gi2/0/23, Gi2/0/24
                                                Gi2/0/25, Gi2/0/26, Gi2/0/27
                                                Gi2/0/28
10   Core                             active
20   DMZ                              active
30   Internet                         active
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        0      0
10   enet  100010     1500  -      -      -        -    -        0      0
20   enet  100020     1500  -      -      -        -    -        0      0
25   enet  100025     1500  -      -      -        -    -        0      0
30   enet  100030     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      -      -        -    -        0      0
1003 tr    101003     1500  -      -      -        -    -        0      0
1004 fdnet 101004     1500  -      -      -        ieee -        0      0
1005 trnet 101005     1500  -      -      -        ibm  -        0      0

Remote SPAN VLANs
------------------------------------------------------------------------------


Primary Secondary Type              Ports
------- --------- ----------------- ------------------------------------------

DK_Lab_SW#



-----------------------------------------------------------------------------
Assign Interfaces/Ranges of Interfaces to VLAN
-----------------------------------------------------------------------------
dk_Lab_SW#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
dk_Lab_SW(config)#vlan 10
dk_Lab_SW(config-vlan)#interface range Gi2/0/1-10
dk_Lab_SW(config-if-range)#switchport access vlan 10
dk_Lab_SW(config-if-range)#no shutdown
dk_Lab_SW(config-if-range)#exit
dk_Lab_SW(config)#exit
dk_Lab_SW#


dk_Lab_SW(config)#vlan 20
dk_Lab_SW(config-vlan)#interface range Gi2/0/11-16
dk_Lab_SW(config-if-range)#switchport access vlan 20
dk_Lab_SW(config-if-range)#no shutdown
dk_Lab_SW(config-if-range)#^Z
dk_Lab_SW#


dk_Lab_SW#config t
Enter configuration commands, one per line.  End with CNTL/Z.
dk_Lab_SW(config)#vlan 30
dk_Lab_SW(config-vlan)#interface range Gi2/0/17-24
dk_Lab_SW(config-if-range)#switchport access vlan 30
dk_Lab_SW(config-if-range)#no shutdown
dk_Lab_SW(config-if-range)#^Z
dk_Lab_SW#

dk_Lab_SW#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
dk_Lab_SW#


dk_Lab_SW#sh vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Gi2/0/25, Gi2/0/26, Gi2/0/27
                                                Gi2/0/28
10   Core                             active    Gi2/0/1, Gi2/0/2, Gi2/0/3
                                                Gi2/0/4, Gi2/0/5, Gi2/0/6
                                                Gi2/0/7, Gi2/0/8, Gi2/0/9
                                                Gi2/0/10
20   DMZ                              active    Gi2/0/11, Gi2/0/12, Gi2/0/13
                                                Gi2/0/14, Gi2/0/15, Gi2/0/16
30   Internet                         active    Gi2/0/17, Gi2/0/18, Gi2/0/19
                                                Gi2/0/20, Gi2/0/21, Gi2/0/22
                                                Gi2/0/23, Gi2/0/24
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        0      0
10   enet  100010     1500  -      -      -        -    -        0      0

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
20   enet  100020     1500  -      -      -        -    -        0      0
30   enet  100030     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      -      -        -    -        0      0
1003 tr    101003     1500  -      -      -        -    -        0      0
1004 fdnet 101004     1500  -      -      -        ieee -        0      0
1005 trnet 101005     1500  -      -      -        ibm  -        0      0

Remote SPAN VLANs
------------------------------------------------------------------------------


Primary Secondary Type              Ports
------- --------- ----------------- ------------------------------------------

dk_Lab_SW#


-----ADDING IP ADDRESS TO VLANs----------------------------------------------
dk_Lab_SW#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
dk_Lab_SW(config)#interface vlan 10
dk_Lab_SW(config-if)#
00:30:59: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to down
dk_Lab_SW(config-if)#ip address 172.20.35.243 255.255.255.248
dk_Lab_SW(config-if)#description Landmark Core
dk_Lab_SW(config-if)#no shutdown
dk_Lab_SW(config-if)#^Z
dk_Lab_SW#



dk_Lab_SW#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
dk_Lab_SW(config)#interface vlan 20
00:37:15: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan20, changed state to down
dk_Lab_SW(config-if)#ip address 10.210.4.49 255.255.255.240
dk_Lab_SW(config-if)#description Landmark DMZ
dk_Lab_SW(config-if)#no shutdown
dk_Lab_SW(config-if)#^Z
dk_Lab_SW#



dk_Lab_SW#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
dk_Lab_SW(config)#int vlan 30
00:43:39: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan30, changed state to downs
dk_Lab_SW(config-if)#ip address 216.118.190.11 255.255.255.128
dk_Lab_SW(config-if)# description Landmark Internet
dk_Lab_SW(config-if)#no shutdown
dk_Lab_SW(config-if)#exit
dk_Lab_SW(config)#exit
dk_Lab_SW#


dk_Lab_SW#copy running-config st
dk_Lab_SW#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
dk_Lab_SW#

--------------------------------------------------------------------------------------------------
Validate VLAN IPs   - Note for protocol to turn up at least one Interface in the VLAN needs to be plugged in

dk_Lab_SW#sh ip int brief
Interface              IP-Address      OK? Method Status                Protocol
Vlan1                  unassigned      YES unset  up                    down
Vlan10                 172.20.35.243   YES manual up                    down
Vlan20                 10.210.4.49     YES manual up                    down
Vlan30                 216.118.190.11  YES manual up                    down
GigabitEthernet2/0/1   unassigned      YES unset  down                  down
GigabitEthernet2/0/2   unassigned      YES unset  down                  down
GigabitEthernet2/0/3   unassigned      YES unset  down                  down
GigabitEthernet2/0/4   unassigned      YES unset  down                  down
GigabitEthernet2/0/5   unassigned      YES unset  down                  down
GigabitEthernet2/0/6   unassigned      YES unset  down                  down
GigabitEthernet2/0/7   unassigned      YES unset  down                  down
GigabitEthernet2/0/8   unassigned      YES unset  down                  down
GigabitEthernet2/0/9   unassigned      YES unset  down                  down

Here I plugged in my laptop on GigabitEthernet2/0/5 on the switch (note VLAN 10 Came up and Gi2/0/5 also came up)
--------------------------------------------------------------------------------------------------

dk_Lab_SW#sh ip int brief
Interface              IP-Address      OK? Method Status                Protocol
Vlan1                  unassigned      YES unset  up                    down
Vlan10                 172.20.35.243   YES manual up                    up
Vlan20                 10.210.4.49     YES manual up                    down
Vlan30                 216.118.190.11  YES manual up                    down
GigabitEthernet2/0/1   unassigned      YES unset  down                  down
GigabitEthernet2/0/2   unassigned      YES unset  down                  down
GigabitEthernet2/0/3   unassigned      YES unset  down                  down
GigabitEthernet2/0/4   unassigned      YES unset  down                  down
GigabitEthernet2/0/5   unassigned      YES unset  up                    up
GigabitEthernet2/0/6   unassigned      YES unset  down                  down






verify vlan interfaces

dk_Lab_SW#sh ip int vlan 10
Vlan10 is up, line protocol is down
  Internet address is 172.20.35.243/29
  Broadcast address is 255.255.255.255
  Address determined by setup command
  MTU is 1500 bytes
  Helper address is not set
  Directed broadcast forwarding is disabled
  Outgoing access list is not set
  Inbound  access list is not set
  Proxy ARP is enabled
  Local Proxy ARP is disabled
  Security level is default
  Split horizon is enabled
  ICMP redirects are always sent
  ICMP unreachables are always sent
  ICMP mask replies are never sent
  IP fast switching is disabled
  IP CEF switching is disabled
  IP Null turbo vector
  IP Null turbo vector
  IP multicast fast switching is enabled
  IP multicast distributed fast switching is disabled
  IP route-cache flags are Fast
  Router Discovery is disabled
  IP output packet accounting is disabled
  IP access violation accounting is disabled
  TCP/IP header compression is disabled
  RTP/IP header compression is disabled
  Probe proxy name replies are disabled
  Policy routing is disabled
  Network address translation is disabled
  BGP Policy Mapping is disabled
  WCCP Redirect outbound is disabled
  WCCP Redirect inbound is disabled
  WCCP Redirect exclude is disabled
dk_Lab_SW#
dk_Lab_SW#
dk_Lab_SW#sh ip int vlan 20
Vlan20 is up, line protocol is down
  Internet address is 10.210.4.49/28
  Broadcast address is 255.255.255.255
  Address determined by setup command
  MTU is 1500 bytes
  Helper address is not set
  Directed broadcast forwarding is disabled
  Outgoing access list is not set
  Inbound  access list is not set
  Proxy ARP is enabled
  Local Proxy ARP is disabled
  Security level is default
  Split horizon is enabled
  ICMP redirects are always sent
  ICMP unreachables are always sent
  ICMP mask replies are never sent
  IP fast switching is disabled
  IP CEF switching is disabled
  IP Null turbo vector
  IP Null turbo vector
  IP multicast fast switching is enabled
  IP multicast distributed fast switching is disabled
  IP route-cache flags are Fast
  Router Discovery is disabled
  IP output packet accounting is disabled
  IP access violation accounting is disabled
  TCP/IP header compression is disabled
  RTP/IP header compression is disabled
  Probe proxy name replies are disabled
  Policy routing is disabled
  Network address translation is disabled
  BGP Policy Mapping is disabled
  WCCP Redirect outbound is disabled
  WCCP Redirect inbound is disabled
  WCCP Redirect exclude is disabled

dk_Lab_SW#
dk_Lab_SW#
dk_Lab_SW#sh ip int vlan 30
Vlan30 is up, line protocol is down
  Internet address is 216.118.190.11/25
  Broadcast address is 255.255.255.255
  Address determined by setup command
  MTU is 1500 bytes
  Helper address is not set
  Directed broadcast forwarding is disabled
  Outgoing access list is not set
  Inbound  access list is not set
  Proxy ARP is enabled
  Local Proxy ARP is disabled
  Security level is default
  Split horizon is enabled
  ICMP redirects are always sent
  ICMP unreachables are always sent
  ICMP mask replies are never sent
  IP fast switching is disabled
  IP CEF switching is disabled
  IP Null turbo vector
  IP Null turbo vector
  IP multicast fast switching is enabled
  IP multicast distributed fast switching is disabled
  IP route-cache flags are Fast
  Router Discovery is disabled
  IP output packet accounting is disabled
  IP access violation accounting is disabled
  TCP/IP header compression is disabled
  RTP/IP header compression is disabled
  Probe proxy name replies are disabled
  Policy routing is disabled
  Network address translation is disabled
  BGP Policy Mapping is disabled
  WCCP Redirect outbound is disabled
  WCCP Redirect inbound is disabled
  WCCP Redirect exclude is disabled
dk_Lab_SW#


dk_Lab_SW# sh vlan summary
Number of existing VLANs           : 8
 Number of existing VTP VLANs      : 8
 Number of existing extended VLANs : 0

dk_Lab_SW#sh vtp status
VTP Version                     : running VTP1 (VTP2 capable)
Configuration Revision          : 0
Maximum VLANs supported locally : 1005
Number of existing VLANs        : 8
VTP Operating Mode              : Transparent
VTP Domain Name                 : LanSrv
VTP Pruning Mode                : Disabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0x8D 0x3B 0xF7 0x3F 0x9B 0x51 0x99 0xF7
Configuration last modified by 0.0.0.0 at 0-0-00 00:00:00
dk_Lab_SW#





=====
Additional Info
It is because of Autostate is implemented on CatOS and IOS Cisco based switches by default. On some CatOS platforms, this feature can be disabled in

order to allow redundancy in special scenarios. On IOS based switches, this feature cannot be disabled.

The router VLAN interfaces have to fulfill the following general conditions to be up/up:
    *  VLAN exists and is in active status on the switch VLAN database.
    *  VLAN interface exists on the router and is not administratively down.
    *  At least one L2 (access port or trunk) port exists and has a link up on this VLAN. The latest implementation of the autostate feature allows

synchronization to Spanning-Tree Protocol (STP) port status.A VLAN interface will be brought up after the L2 port has had time to converge (that is,

transition from listening-learning to forwarding). This will prevent routing protocols and other features from using the VLAN interface as if it were

fully operational. This also prevents other problems, such as routing black holes, from occurring.
    * At least one L2 (access port or trunk) port is in spanning-tree forwarding state on the VLAN.

NOTE at least one device needs to be plug in the VLAN before the protocol is turned up!

No comments:

Post a Comment