- permit - only allow routes; denied ones will stay in route bucket
- deny - matching routes will be removed from bucket and discarded
Matching
config-route-map# match interface <type> <number>
config-route-map# match ip address [<acl> | prefix-list <list>]
config-route-map# match ip next-hop <acl>
config-route-map# match ip route-source <acl>
config-route-map# match metric [+/- deviation] (for range of metrics)
config-route-map# match route-type [internal | external [type-1 | type-2 | level-1 | level-2]]
config-route-map# match tag <value>
Setting
config-route-map# set level [level-1 | level-2 | level-1-2 | stub-area | backbone]
config-route-map# set metric <value> (ospf, rip, is-is)
config-route-map# set metric <bandwidth> <delay> <reliability> <loading> <mtu> (igrp, eigrp)
config-route-map# set metric-type [internal | external | type-1 | type-2] (is-is, ospf)
config-route-map# set tag <value>
Redistribute a static or directly connect routes into OSPF
MUST follow this order
1. create prefix list
2. create router map
3. create ospf redistribution
see example in router
Step 1
ip prefix-list connected_into_ospf seq 5 permit 10.85.246.2/32 (prefix listed for the router map)
!
ip prefix-list static_into_ospf seq 5 permit 10.85.246.128/25
Step 2
!
route-map connected_into_opsf permit 10
match ip address prefix-list connected_into_opsf
set tag 1002
!
Step 2
router ospf 3738
log-adjacency-changes
area 853 authentication message-digest
redistribute connected metric-type 1 subnets route-map connected_into_opsf
redistribute static metric 1 subnets route-map static_into_ospf
passive-interface Loopback0
network 10.85.246.12 0.0.0.3 area 853
No comments:
Post a Comment